
Rendering 
Rendering is the final stage in the 3D computer graphics production process. 
Rendering is the process of generating an image from a 2D or 3D model (or models in 

what collectively could be called a scene file) by means of computer programs. Also, the 

results of such a model can be called a rendering. A scene file contains objects in a 
strictly defined language or data structure; it would contain geometry, 

viewpoint,texture, lighting, and shading information as a description of the virtual scene. 

The data contained in the scene file is then passed to a rendering program to be 
processed and output to a digital image or raster graphics image file. 

Visualization vs. the final render 

As you build your scenes (shade and texture objects, light scenes, position cameras, 
and so on), you’ll want to visualize your scene many times before you produce the final 
rendered image or image sequence. This process may involve (depending on your 
particular project) creating and setting up additional cameras. 

Visualize a scene during early iterations to detect and correct image quality problems or 
to estimate and reduce the amount of time the final render takes before you spend time 
performing the final render. 

When you are satisfied with the results of your scene during test renders, you can 
perform the final render. 

Software rendering 

Software rendering produces images of the highest quality, letting you achieve the most 
sophisticated results. 

Computation occurs on the CPU, as opposed to hardware rendering, which relies on the 
machine’s graphics card. Because it is not restricted by the computer's graphics card, 
software rendering generally is more flexible. The trade-off, however, is that software 
rendering is generally more time consuming. 

Exactly what you can render depends on which software renderer you use and its 
particular limitations. 

Maya has the following software renderers: 

 The Maya software renderer 

Maya’s software renderer is an advanced, multi-threaded renderer. It is based on a 
rendering technology that is built directly into Maya's dependency graph architecture, 
which means its feature nodes can be intimately connected with any other feature in 
Maya. It provides artists with an excellent general purpose rendering solution with very 
broad capabilities. 

It is a hybrid renderer, offering true raytracing plus the speed advantages of a scan-line 
renderer. The Maya software renderer, while not slow, tends to favor quality and wide 
breadth of capability over raw speed. 

The Maya software renderer supports all of the various entity types found within Maya 
including particles, various geometry and paint effects (as a post render process) and 
fluid effects. It also has a robust API for the addition of customer-programmed effects. 
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The Maya software renderer features IPR (Interactive Photo Realistic rendering), a tool 
designed to allow you to make interactive adjustments to the final rendered image, and 
which greatly enhances rendering productivity. Most importantly, the nature of Maya's 
integrated architecture allows complex interconnections, like procedural textures and 
ramps that govern particle emission and other unpredictable relationships that are 
capable of producing stunning visual effects. 

 

 NVIDIA® mental ray® for Maya® 

Hardware rendering 

Hardware rendering uses the computer's video card and drivers installed on the machine 
to render images to disk. Hardware rendering is generally faster than software rendering, 
but typically produces images of lower quality compared to software rendering. In some 
cases, however, hardware rendering can produce results good enough for broadcast 
delivery. 

Hardware rendering cannot produce some of the most sophisticated effects, such as 
some advanced shadows, reflections, and post-process effects. To produce these kind 
of effects, you must use software rendering. 

Maya has the following hardware renderers: 

 The Maya hardware renderer 

Maya’s hardware renderer presents a seamlessly integrated rendering solution that 
leverages the ever increasing power of next-generation graphics cards to render frames. 

Benefits include an intuitive workflow to generate hardware rendered images for 
previews, specific passes, and hardware rendered particles. You can render and display 
images using the Render View, which lets you compare images during the shading and 
lighting tasks. 

The user experience and the visual quality of the final images significantly surpass that 
of the Hardware Render Buffer window. You can produce broadcast-resolution images 
in less time than with software rendering. In some cases, the quality may be good 
enough for final delivery. 

The hardware renderer uses Maya's existing interface and workflow for assigning 
shaders, textures, particles, light linking, and so on. 

To prevent the windows of other applications from interfering with the rendering of the 
image, you can perform off-screen batch rendering. 

Maya Hardware 2.0 renderer 

Use the Maya Hardware 2.0 renderer to perform command line rendering for Viewport 
2.0, or to batch render to disc or to Render View. 

 Viewport 2.0 

On systems with sufficient memory and graphic cards, Viewport 2.0 provides large 
scene performance optimization and higher quality lighting and shaders. It allows for 
high interactivity: you can tumble complex scenes with many objects as well as large 
objects with heavy geometry. 
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Vector rendering 

Vector rendering lets you create stylized renderings (for example, cartoon, tonal art, line 
art, hidden line, wireframe) in various bitmap image formats and 2D vector formats. 

You can use the Maya Vector renderer to create stylized renderings (for example, 
cartoon, tonal art, line art, hidden line, wireframe) in various bitmap image formats (for 
example, IFF, TIFF, and so on) or in the following 2D vector formats: 

 Adobe® Flash® (non-interactive) version 3, 4 or 5 (SWF) 

 Adobe® Illustrator® version 8 (AI) 

 Encapsulated PostScript Level 2 (EPS) 

 Scalable Vector Graphics (SVG). 

 

To choose the renderer 

1. Do one of the following: 

 Click Render > Render Using, then choose the renderer. 

 Select the renderer from the drop-down list in Render View (Window > Rendering 
Editors > Render View). 

 Select the renderer from the drop-down list in the Render Settings window. 

 

Anti-aliasing and flicker 

 

Jagged or stair-cased edges in pixel-based images or flickering surfaces in an animation 
are aliasing artifacts. 

Aliasing artifacts result from point sampling, a process used in all computer graphics 
applications that determines the information about each pixel. Aliasing artifacts can 
result at various stages during any rendering process. 

Anti-aliasing is the process of removing or reducing these artifacts. Because there are 
many kinds of aliasing, such as grainy surfaces, flickering, and jagged edges, there are 
as many approaches to controlling or fixing these problems. You can make adjustments 
to a number of settings to decrease or eliminate aliasing artifacts and flicker. 
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Artifacts 

 

Artifacts can show up as unintentional blotches, bands or cross-hatches on surfaces. 
Textures can flicker or crawl on surfaces from frame to frame during animations. 

Clipping plane artifacts 

Especially in large scenes that have objects close together, background surfaces may 
appear to show through nearby surfaces. This is a result of how the camera’s clipping 
planes determine the depth position of geometry; the problem results from the limited 
precision used to store depth information. It is mainly influenced by the following camera 
parameters: near clip distance, far clip distance, and camera angle. 

 

Introduction to Tessellation and Approximation 

SHARE 

LIKE (0) 

 

Tessellation is the process renderers use to convert NURBS surfaces (or displacement 
mapped polygon meshes) to triangles. Triangles determine how smooth an object looks 
at closer distances to you (the camera). When poorly tessellated objects are close to the 
camera, they appear faceted; when they are further away, they don’t 

. 
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When to adjust tessellation 

Because (most) renderers can only render triangles, tessellation is a necessary and 
automatic step that occurs at render time. However, you need to adjust tessellation 
settings when objects aren’t smooth enough, which typically happens as objects come 
close to the camera or if objects are displacement mapped. 

Tessellation settings determine how many triangles are used, where the triangles are 
concentrated, and what size they are. Numerous and concentrated triangles increase 
the memory requirements (which in turn decrease performance) of the renderer, so you 
must adjust tessellation settings to strike a balance between smooth edges (quality) on 
objects that are closer to the camera and renderer performance (the time it takes to 
render). 

Tessellation strategy always is to adjust the settings, per-object (not globally), only high 
enough to achieve a smooth surface. Distant and less-important objects can have lower 
tessellation settings than objects closer to the camera. 

 

Batch renders from within Maya (UI) 

If you want to render an animation, start a batch render from within the Maya UI. (You 
can also render a single frame this way.) Advantages include the following: 

 easy to use 

 you can continue to use the Maya UI 

 you can start a batch render while you continue to work within Maya 

 you can interrupt the render at any time from within Maya 

 

Interactive Photorealistic Rendering (IPR) 

IPR is available only for Maya software rendering and mental ray for Maya rendering. 

 

IPR, a component of the Render View rendering, lets you preview and adjust lights, 
shaders, textures, and 2D motion blur quickly and efficiently. 
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IPR is ideal for visualizing your scene as you work because it almost immediately shows 
the changes you make. You can also pause and stop IPR rendering and select several 
rendering options to be included or excluded from the IPR process. IPR works a little 
differently than regular software rendering; IPR doesn't support all software renderable 
features (for example, raytracing or production quality anti-aliasing are not supported).  

How IPR works 

When you start an IPR session, Maya computes the initial IPR image, which is a deep 
raster format that contains more than just the final picture. Maya performs all the visibility 
calculations (only once), and stores the results in a file in the iprImages directory. 

An IPR image is an IFF image with additional data. It is larger than a regular image file 
because it stores both visibility and shading data. The data is computed in the following 
ways: 

 Visibility calculations compute where items are located in the scene, or what is visible 
to the camera (or to the light, for depth maps for shadowing) at each pixel in the 
image. 

 Shading calculations compute what color is displayed at each pixel of the image. 

It takes longer to perform an IPR render than it does to perform a software render 
because more information is written to disk. The IPR image contains the information 
needed to perform the shading calculations for each pixel in the image as you adjust 
scene parameters. 

When you select a region to adjust, Maya loads all the necessary information into 
memory for all the pixels in the selected region. 

As you modify scene attributes, Maya recomputes the shading calculations and the 
selected region in Render View updates. 

Since none of the visibility calculations have to be recomputed at this stage, tuning 
updates much faster than a full software rendering. 

IPR images can be very large (for example, at NTSC Video resolution, a single IPR 
image could be up to 60MB). Make sure you have adequate disk space for your IPR 
image before you perform an IPR Render. 

Note: An IPR default light source (created during IPR rendering) works in a similar way 

to the software renderer’s default light source: 

 The IPR default light source is removed from the scene as soon as the IPR session is 
terminated (for example, when you click the IPR stop button). 

 The IPR default light source is not saved with the scene, preventing you from 
accidentally adding the IPR default light to the saved scene. 
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IPR Limitations (for Maya software renderer) 

Visibility limitations 

Any change to an attribute that affects the visibility calculation, such as changing the 
camera angle, adding or removing a surface, or transforming CVs on a surface, requires 
another IPR render before you can see the effect of that change. 

Transformations affect visibility when applied to an object or camera (like moving an 
object or zooming the view, since moving an object or the camera may change what is 
visible at each pixel). This does not include lighting changes; they are supported. 

Adding or removing surfaces, UV mapping values 

If you add surfaces to or remove surfaces from the scene, or if you change the UV 
mapping values for a texture, you must perform another IPR render before you see the 
change. Examples of these kinds of changes include: 

 When you select a new group of faces on a polygonal surface, even if the surface is 
already in the scene. In IPR, selecting a new group of faces to texture is equivalent to 
creating a new surface. 

 Turning Fix Texture Warp on/off changes how UV mapping values are generated in an 
IPR render. This situation is analogous to modifying polygon UVs by changing their 
placement. 

 Editing UVs in the texture window. 

Changing image planes, shadow maps, background color 

If you make changes to shadow map resolution, image planes, or background color, you 
must manually update the IPR tuning region (select IPR > Update Shadow Mapsor IPR 
> Update Image Planes/Background). 

General limitations for Maya Software Renderer IPR 

 raytracing effects (for example, transparency, reflection, refractions) 

 particles 

 3D motion blur 

 anti-aliasing: adaptive shading, multi-pixel filtering 

 global override of Enable Depth Maps attribute (in the Render Settings window) does 
not function properly 

 output to IFF (deep raster) 

Mac OS X-specific limitations 

 Cannot render interactively with resolution of 4K or higher 

 If you render an image successfully and then render it again with a lower resolution, 
the rendered image does not reduce in size. 

Image plane limitations 

 Only supports file mode, not texture mode. 
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 Changes to file mode do not IPR render properly unless you turn on “Update Image 
Planes/Background” per change. 

Shader and Texture limitations 

 Use Background shader is not well supported because it relies on raytracing. 

 Modifying, adding, or deleting a displacement map applied to the geometry requires 
re-rendering. 

 Turning on advanced filters (such as quadratic, cubic, or Gaussian) in the file texture 
requires re-rendering. Much more information needs to be stored into the IPR image, 
unless the render was originally generated with the advanced filter turned on. 

Geometry changes that require IPR re-rendering 

 Adding or deleting geometry. 

 Transforming or morphing geometry. 

 Changing tessellation. 

 Turning on/off Fix Texture Warp for the surface, or modifying any Fix Texture 
Warp attributes. 

Glow limitations 

 Light glow intensity may appear different because the light glow occlusion is computed 
at the time of the IPR generation. If the light is moved where the light glow occlusion 
changes, an inaccurate glow intensity could result. 

 Shader glow may look different because the IPR region (not covering the entire scene) 
produces a different auto-exposure normalization. 

Others 

 Changing blur-by-frame does not update the IPR unless you re-render. 

 2D motion blur won’t be exactly right because you work on a smaller region. 

 

Render from a command line 

You can render from a command line if you want to render an animation or single frame. 
Advantages include the following: 

 works with single images and animation 

 uses less memory than having all of Maya (UI) running 

 can be scripted 

 can be integrated into a rendering pipeline (render farms) 

 for Maya software rendering, you can override render settings using command flags 
(for other renderers, you must also write a MEL script) 
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test render a low-res still or frame 

The time Maya takes to software render a scene is directly proportional to the resolution: 
the larger the resolution, the more time it takes. 

If you want to get a feel for the final rendered look quickly, you can render of a still image 
or single frame of an animation. Typically, a resolution half to a quarter of the size lets 
you get a good feel for the software rendered look. 

Note: 

To ensure the best quality display of your rendered image, select the 1:1 (the real size) 
option in Render View before you render. 

To test render a still image 

1. From Render View (Window > Rendering Editors > Render View), click Options > Test 
Resolution, then select a resolution. 

2. Select the camera view you want to render from the Render > Render submenu. 

Maya renders the scene and displays the image as it renders in Render View. 

 To cancel the render, press Esc. 

 To re-render the frame, select Render > Redo Previous Render. 

 

Render a single frame 

When you render or re-render a single frame from Maya’s main window, the render 
appears in Render View. For more information about using Render View, see Render 
View rendering. 

The image is automatically saved to the images directory of the current project. 

Tip: Render at 1:1 resolution for fastest feedback. 

Note: Navigation in the Render View panel is like most other Maya view panels. You can 

zoom and track the view using the same keyboard shortcuts. 

To render a frame from within Maya 

1. From the main Maya window, click the Render Current Frame button, or select Render 
> Render Current Frame. 

Maya renders the current scene and displays the image as it renders in Render View. 

To re-render a frame from within Maya 

1. From the main Maya window, select Render > Redo Previous Render. 

Maya renders the scene from the previous camera and displays the image as it 
renders in the Render View window. 

To cancel the in-progress render 
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1. Press Esc. 

 

File formats 

Maya can save rendered image files in several standard image file formats. 

By default, Maya saves rendered image files in the Maya Image File Format (Maya IFF). 
The Maya IFF is the most efficient format, in which no data loss occurs. All other file 
formats are translated from the Maya IFF format. 

 

or more information on mental ray specific image formats, see mental ray for Maya 
rendering. 

File Format Class 
Maya 

Software 

Maya 

Hardware 

Maya 

Hardware 

2.0 

Maya 

Vector 

mental 

ray 

Adobe® Illustrator®(.ai) Vector -- -- -- 
 

-- 

Alias PIX (.als) Movie 
     

AVI (.avi) Movie 
     

Cineon (.cin) -- 
   

-- 
 

DDS (.dds) -- 
   

-- 
 

Encapsulated Postscript 

(.eps) 

Vector -- -- -- 
 

-- 

EPS (.eps) -- 
   

-- 
 

GIF (.gif) -- 
   

-- 
 

JPEG (.jpg) -- 
   

-- 
 

MacPaint (.pntg) Mac -- -- -- -- -- 

Adobe ®SWF (.swf) Vector -- -- -- 
 

-- 

Maya IFF (.iff) -- 
   

-- 
 

Maya16 IFF (.iff) 16-bit 
    

-- 

PNG (.png) PSD 

Layered 
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File Format Class 
Maya 

Software 

Maya 

Hardware 

Maya 

Hardware 

2.0 

Maya 

Vector 

mental 

ray 

PNG (.png) -- 
   

-- 
 

PSD (.psd) -- 
   

-- 
 

PSD Layered (.psd) PSD 

Layered 
     

Quantel (.yuv) Quantel 
    

-- 

QuickDraw (.pict) Mac -- -- -- -- -- 

Apple® Quicktime®Image 

(.qtif) 

Mac -- -- -- -- -- 

RLA (.rla) -- 
   

-- 
 

SGI® (.sgi) -- 
   

-- 
 

SGI16 (.sgi) 16-bit 
    

-- 

SoftImage® (.pic) -- 
   

-- 
 

SVG (.svg) Vector -- -- -- 
 

-- 

Swift3DImporter (.swft) Vector -- -- -- 
 

-- 

Targa (.tga) -- 
   

-- 
 

Tiff (.tif) -- 
   

-- 
 

Tiff16 (.tif) -- 
   

-- 
 

Windows® Bitmap (.bmp) -- 
   

-- 
 

EXR(exr) -- -- --  

 

-- 
 

Note: Export of .avi files limited to a size of 2GB. 

Image formats are divided into seven classes: Vector, Movie, Sixteen Bit, PSD Layered, 
Quantel, and Mac. A description of each class is listed below: 

Vector 
An image format comprised of segments of vector data. Vector graphics are 
resolution independent: they appear smooth and crisp regardless of the 
magnification level. 
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True Vector 
True vector art outlines every line in the figure and contains points. 

Movie 
An image format used to store video and audio information. This information can 
be played back as a sequence of images from within the movie file. 

Sixteen Bit 
A bitmap image format. Bitmaps store a single raster image in any color depth. 
For a 16-bit image, thirty-two thousand different colors can be represented. 
Unlike vector images, bitmap images are resolution dependent: image 
degradation occurs when images are magnified at a high level. 

PSD Layered 
Photoshop Drawing Layered image format. Layers are independent images that 
can be manipulated in Adobe Photoshop. PSD layered images can be multi-
layered. In multi-layered images, each layer is a part of the final image. You can 
work on each layer independently without interference from any graphical 
elements that are on other layers. 

Quantel 
An image format made by Quantel. This 16-bit uncompressed image format 
contains video and RGB channels. Quantel image formats are typically used for 
broadcast. 

Mac 
An image format unique to Macintosh applications. These formats are only 
supported on Macintosh machines. 

 

Frames vs. Fields 

Only the Maya software renderer supports field rendering. 

Motion picture film and video simulate motion by displaying a continuous sequence of 
images or frames. There are, however, important differences in the way film and video 
systems display individual frames which may affect how you render images. 

 

Pixel aspect ratio 

A rendered bitmapped image file consists of numerous rectangular pixels (picture 
elements). The size of a rendered image is measured by the number of pixels it contains 
horizontally and vertically, and by the aspect ratio of individual pixels (whether pixels are 
square or rectangular). 

Most display devices (for example, a computer monitor) have square pixels, and 
their Pixel Aspect Ratio is 1. Some devices, however, have non-square pixels (for 
example, NTSC video has a Pixel Aspect Ratio of 0.9). 

 

www.a2zpapers.com
Download free old Question papers gndu, ptu hp board, punjab board

w
w
w
.
a
2
z
p
a
p
e
r
s
.
c
o
m

www.a2zpapers.com

a2zpapers.com

http://a2zpapers.com/
www.a2zpapers.com
http://a2zpapers.com/


Master layers and layer membership 

The Master layer contains all the objects and materials in the scene. There is always a 
Master layer in your scene; it’s exposed in the Render Layer editor. It is only visible in 
the Render Layer editor if there is more than one layer (in which case it is non-
renderable by default). 

When you create new layers, you can make any objects or nodes (including lights) 
members of only that layer, multiple layers, or all layers. Only objects in a specific layer 
affect or contribute to that layer; this includes lights, reflections, shadows, and so on. 

In addition to segmenting your scene into render layers, you can change the 
characteristics of each layer or object on a layer by creating layer overrides. (By 
definition, you can't override the characteristics of the Master layer.) Maya stores each of 
the layer and attribute overrides as changes between that layer and the Master layer. 
See the next section. 

Changes to a layer or to objects on a layer (overrides) 

There are two types of overrides for attributes: per layer and per object. 

 Per layer overrides change attributes, characteristics, or material assignments that 
affect the entire layer. This can include the renderer for the layer, the image size for 
the rendered image of that layer, whether or not all objects on the layer cast shadows 
or receive shadows, or a material assigned to all objects in the layer. 

 Per object overrides change the value of an attribute or material assignment on an 
object in a specific layer on which overrides exist. This can include the material 
assignment for an object on the layer, render stats for that object (such as casting or 
receiving shadows), or attributes of the object, or on per-object shaders (such as 
transparency). 

There are two ways to create overrides: auto and manual. 

 Auto overrides immediately change the value of the attribute to be different than the 
one specified on the Master layer, without any additional action required on your part. 

 Manual overrides require you to explicitly tell Maya that you want that attribute value to 
be different than the one specified on the Master layer. 

o Per layer auto-overrides include shader assignments (to all objects in a layer); 
see Work with layer overrides. 

o Per layer manual overrides include changes to per-layer render settings and 
member overrides (render stats). See Work with layer overrides. 

o Per object auto-overrides include material assignments to objects; see Work with 
attribute overrides. 

o Per object manual overrides include all other attribute change; see Work with 
attribute overrides. 

Viewing layers and managing layers 

Render layers affect the scene view, Hypergraph, Hypershade, and so on. Switching 
layers means that lights, geometry, or nodes are visible or not depending on whether 
those objects are in a particular render layer. (Previously, objects always appeared in 
the scene view and were either present or not present in a render.) 
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Visibility of Display layers and Render layers interact subtractively. That is, if you have a 
Display layer that contains objects and turn off visibility on that layer, you will also not 
see these objects in any of your Render layers. 

 There are three different ways to create per-layer changes: 

o overrides that affect the entire layer 

o auto-overrides to render stats or material assignment of an object on a layer 

o manual overrides to any other attribute. 

What you can do with render layers: summary 

Once you understand the basic concepts of Master layer, layer and object overrides 
(auto or manual), render settings, and presets, you can do the following on a layer-by-
layer basis: 

 select the renderer and override Render Settings (formerly known as Render Globals) 
both in the Common tab and in the renderer-specific tab. 

 create layer overrides. You can override settings that affect rendering; for example, 
you can turn off Cast Shadows and turn on Visible in Refractions and Visible in 
Reflections for a layer. 

 override material assignments: 

o per component (for example, assign certain faces a different material for any layer). 

o per object (for example, assign certain surfaces a different material for any layer) 

 override any renderable attribute (for example, set a different value for transparency 
on a object on a particular layer) 

 assign the blending modes for layers directly in the Render layer editor, and preview 
the layer composite in the Render View. 

 

Render layer overview 

A system of per layer and per object overrides means that objects can have different 
shading and rendering attributes on different layers. 

With render layers, you can assign any object to multiple layers with a different material 
on each layer. This lets you create multiple images for each frame, from any 
combination of Maya's four renderers, third party plug-in renderers, and post- processes 
such as Fur and Paint Effects. Rendered images can be efficiently organized for output 
to a compositor. Render layers can be also be rendered to Adobe® Photoshop® (PSD) 
format, which supports multiple image layers. 

As well, a preview composite of all the layers can be viewed in the Render View. 

Benefits of render layers 

You can propagate changes across layers that exist in a single scene, rather than 
having to manage multiple scenes. Render layer presets allow easy setup of commonly-
used passes, such as shadows and specularity. Render Layers can also be used to 
prepare different layers in a scene for vertex baking or light mapping. 
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Render passes 

To render various attributes separately, for example, color, shadow, specular shading, 
and so forth, you may want to use render passes. 

Typically you render in passes to render various attributes, such as color, shadows, 
highlights, of your scene separately. You can fine-tune a scene without re-rendering it by 
modifying different passes in a compositing program. 

Beauty pass 

This is the default pass. You can select your render pass from the Attribute Editor of 
your render layer. 

 

It produces a complete rendering of the components produced by a shadow pass and a 
color pass. Because the color pass produces a complete rendering of the components 
produced by a diffuse pass and a specular pass, a beauty pass ends up producing a 
complete rendering of all possible components. 

 

If you need to tweak shadows independently in a compositing package or paint 
application, run the color and shadow passes separately. 

Color pass 

Produces only the color component of the image. No shadow information is produced. 

A color pass is subdivided into a diffuse and specular pass. 

Shadow pass 

Produces only the shadow component of the image. No color information is produced. 

Diffuse pass 

Only diffuse shading is performed. The diffuse pass contains the diffuse and ambient 
information and is modulated by color, transparency, and Diffuse Coeff (diffuse 
coefficient). 
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Specular pass 

Only specular shading is performed. The specular component is modulated differently 
depending on the type of material associated with the object. Phong, PhongE, Blinn, and 
Anisotropic materials produce specular contributions differently. On a Phong material, 
the specular pass can be modulated using cosine power, and specular color. 

 
Note: 

No mask or alpha channel is produced for the Specular Pass, additively compositing a 
specular pass is recommended. 

Custom shadow and reflection passes 

You can also create custom shadow and reflection passes with the useBackground 
material which catches shadow and, or reflections. When the shadow pass is rendered, 
a black image is created with mask channel that contains the shadow information. A 
compositor can work with this channel to blur, lighten, darken, and so on, the look of the 
shadows. When the reflection pass is rendered, an RGB image is created with a white 
mask in the mask channel. 

 

Render tiles in the Maya Software renderer 

The Maya Software renderer renders an image as a series of tiles. The renderer tries to 
use a tiling configuration that ensures memory is optimized. Thus, the tiles are smaller in 
the regions of the image where the geometry is dense. The renderer tries to ensure that 
the memory cap specified in Render Settings window is respected. 

 

To render a scene 

1. Decide which renderer you want to use, and set scene options for it: 

2. If you plan to composite your work, you can render your scene in layers and passes. 

3. Make any required per-object adjustments: 
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 adjust the surface quality (tessellation) of objects,. 

 adjust per-object settings; for example, settings for lights, cameras, objects. 

4. Test iterations of your scene to visualize your the changes you make materials, 
textures, lights, cameras, and objects. 

5. When you are satisfied with the results, render the final images. 

 

Render Settings window 

Navigate to Window > Rendering Editors > Render Settings. 

 

Render settings (scene settings) for the Maya Hardware renderer, the mental ray for 
Maya renderer, the Maya Software renderer, the Maya Vector renderer are consolidated 
into one Render Settings window. 

Use the settings in this window to set scene-wide render options. Especially when used 
in conjunction with per-object render settings (see the particular object or render subject 
matter for details), the render settings give you a great deal of control over quality of 
rendered images and the speed with which they are rendered. 

Render Layer 

Select from the drop-down list the layer that you want to render from. 

Presets 

Use the Presets menu to save your current settings as a preset and avoid having to 
adjust them each time you render. 

Render Using 

Select from the drop-down list the renderer that you want to use. 

Common tab 

The common tab contains settings that are common to all renderers 

Color Management 

Enable Color Management 

Default Input Profile 

Default Output Profile 
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File Output 

The name of rendered image files can consist of three separate components: file 
name, frame number extension, and file format extension. A combination of 
these three components is referred to as the file name syntax. 

File name prefix 

 the File name prefix attribute to add one or more of these fields to the file 
name for your scene, for example, scene name, layer name, camera name, 
version number, current date or current time. Each of these fields are described 
in more detail below. 

You can also create subdirectories to save out rendered images by adding a / 
(slash) in your file name prefix 

Frame Range 

Start frame, End frame 

Specifies the first (Start frame) and last (End frame) frames to render. Start 
Frame and End Frame are only available if Frame/Animation ext is set to an 
option containing # (see also Set file name syntax). The default value for Start 
Frame is 1; the default value for End Frame is 10. 

By frame 

The increment between the frames you want to render. By frame is only available 
if Frame/Animation ext is set to an option containing #. The default value is 1. 

If you use a value less than 1, make sure the Renumber frames using option is 
turned on. Otherwise, many frames will appear to be missing when they are just 
being overwritten. 

Skip existing frames 

Enable this option so that the renderer detects and skips over frames that have 
already been rendered. This feature saves rendering time. 

Renumber frames using 

Lets you change the numbering of rendered image files for an animation. 
The Renumber frames attributes are only available if Frame/Animation ext is set 
to an option with # (such as name.#.ext). 

If on, Maya uses the frame number extensions beginning at Start Number and 
increasing by By Frame for rendered image file names. 

Start number 

The frame number extension you want the first rendered image file name to have. 

By frame 

The increment between frame number extensions you want rendered image file 
names to have. 

Renderable Cameras 

Renderable Cameras 

Render a scene from one or more cameras. The default is to render from one 
camera. 

If you are rendering the scene from one camera (only), select the camera from 
the drop-down list. By default, the perspShape camera is the renderable camera. 
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The drop-down list is divided into sections, separated by dashes: 

 

The first section is the camera currently selected as renderable. 

The second and third sections list existing cameras that you can select as 
renderable, for example, stereo cameras and the front and side cameras. 

Alpha channel (Mask) 

Controls whether rendered images contain a mask channel. The default setting is 
on. 

Depth channel (Z Depth) 

Controls whether rendered images contain a depth channel. The default setting is 
off. 

Remove renderable camera 

To make a camera non-renderable, remove it from the list by clicking the 
 button beside the camera name. You should have at least one renderable 
camera in the scene. The remove button does not appear if only one renderable 
camera is listed. 

Override renderable camera 

On any render layer, you can also override the list of renderable cameras for that 
layer. For example, you can set cameras 1, 3, and 5 as your renderable cameras 
for your master layer and then set cameras 1, 2, and 4 as renderable for layer 1. 
To override the settings in a layer and render the scene from a different camera, 

select the layer, and then, in the Render Settings window,  Renderable 
Camera beside the camera name and select Create Layer Override from the 
drop-down menu that appears.Renderable Camera turns red to indicate that a 
layer override has been incorporated. 

 

Image Size 

The Image Size attributes control the resolution and pixel aspect ratio of rendered 

images. 

Presets 
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Select a film- or video-industry standard resolution. When you select an option 
from 7the Presets drop-down list, Maya automatically sets 
the Width, Height, Device Aspect Ratio, and Pixel Aspect Ratio. 

You can also add a Presets option to output to an unlisted device. 

Maintain width/height ratio 

Turn on this setting when you want to scale the image size proportionally in width 
and height. When you enter a value for either Width or Height, the other value is 
automatically calculated. 

Maintain ratio 

Specifies the type of rendering resolution ratio you want to use, Pixel 
aspect or Device aspect. 

The Pixel aspect ratio is the number of pixels in width to height, that compose the 
image. Most display devices (for example, a computer monitor) have square 
pixels, and their Pixel aspect ratio is 1. Some devices, however, have non-square 
pixels (for example, NTSC video has a Pixel aspect ratio of 0.9). 

The Device aspect ratio is the number of units wide by the number of units high 
of your display. A 4:3 (1.33) display produces an image that is more square, and 
a 16:9 (1.78) ratio produces an image that is more panoramic in shape. 

Width 

Specifies the width of the image in the unit specified in the Size units setting. 

Height 

Specifies the height of the image in the unit specified in the Size units setting. 

Size units 

Sets the unit that you want to specify the image size in. Select from pixels, 
inches, cm (centimeter), mm (millimeter), points and picas. 

Resolution 

Specifies the resolution of the image in the unit specified in the Resolution 
Units setting. TIFF, IFF and JPEG formats are able to store this information, so 
that it is maintained when the image is opened in a third party application such as 
Adobe® Photoshop®. 

Resolution units 

Sets the unit that you want to specify the image resolution. Select from 
pixels/inch or pixels/cm (centimeter). 

Device aspect ratio 

The aspect ratio of the display device on which you view the rendered image. 
The device aspect ratio represents the image aspect ratio multiplied by the pixel 
aspect ratio. 

Pixel aspect ratio 

The aspect ratio of the individual pixels of the display device on which you are 
viewing the rendered image. 
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